In short
- CVE-2017-9785 is a CRITICAL (CVSS 9.8) vulnerability affecting Nancy, nancy (nancyfx).
- Chance of exploitation in the next 30 days (EPSS): 3.0%, higher than 87.5% of all vulnerabilities.
- Fix: update to 2.0.0, 1.4.4 or later.
| Package | Affected versions | Patched versions |
|---|
| Nancy NuGet | ≥ 2.0.0-alpha, < 2.0.0< 1.4.4
| 2.0.01.4.4
|
| nancy | = 2.0.0≤ 1.4.3
| No fix yet |
Description
Csrf.cs in NancyFX Nancy before 1.4.4 and 2.x before 2.0-dangermouse has Remote Code Execution via Deserialization of JSON data in a CSRF Cookie.
NVD description
Csrf.cs in NancyFX Nancy before 1.4.4 and 2.x before 2.0-dangermouse has Remote Code Execution via Deserialization of JSON data in a CSRF Cookie.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free