In short
- CVE-2018-1000058 is a HIGH (CVSS 8.8) vulnerability affecting org.jenkins-ci.plugins.workflow:workflow-support, pipeline supporting apis (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 2.6%, higher than 85.2% of all vulnerabilities.
- Fix: update to 2.18 or later.
Description
Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.
NVD description
Jenkins Pipeline: Supporting APIs Plugin 2.17 and earlier have an arbitrary code execution due to incomplete sandbox protection: Methods related to Java deserialization like readResolve implemented in Pipeline scripts were not subject to sandbox protection, and could therefore execute arbitrary code. This could be exploited e.g. by regular Jenkins users with the permission to configure Pipelines in Jenkins, or by trusted committers to repositories containing Jenkinsfiles.
More vulnerabilities in org.jenkins-ci.plugins.workflow:workflow-support
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free