In short
- CVE-2018-1000162 is a MEDIUM (CVSS 6.1) vulnerability affecting erusev/parsedown, parsedown (parsedown).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.2% of all vulnerabilities.
- Fix: update to 1.7.0 or later.
Description
Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in setMarkupEscaped for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.
NVD description
Parsedown version prior to 1.7.0 contains a Cross Site Scripting (XSS) vulnerability in `setMarkupEscaped` for escaping HTML that can result in JavaScript code execution. This attack appears to be exploitable via specially crafted markdown that allows it to side step HTML escaping by breaking AST boundaries. This vulnerability appears to have been fixed in 1.7.0 and later.
More vulnerabilities in erusev/parsedown
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free