In short
- CVE-2018-1000167 is a HIGH (CVSS 7.8) vulnerability affecting suricata-update, suricata-update (oisf).
- Chance of exploitation in the next 30 days (EPSS): 4.1%, higher than 90.6% of all vulnerabilities.
- Fix: update to 1.0.0b1 or later.
Description
Suricata-Update uses the insecure yaml.load() function. Code will be executed if the yaml-file contains lines like:
hello: !!python/object/apply:os.system ['ls -l > /tmp/output']
The vulnerable function can be triggered by "suricata-update list-sources". The locally stored index.yaml will be loaded in this function and the malicious code gets executed.
NVD description
OISF suricata-update version 1.0.0a1 contains an Insecure Deserialization vulnerability in the insecure yaml.load-Function as used in the following files: config.py:136, config.py:142, sources.py:99 and sources.py:131. The "list-sources"-command is affected by this bug. that can result in Remote Code Execution(even as root if suricata-update is called by root). This attack appears to be exploitable via a specially crafted yaml-file at https://www.openinfosecfoundation.org/rules/index.yaml. This vulnerability appears to have been fixed in 1.0.0b1.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free