In short
- CVE-2018-1000201 is a HIGH (CVSS 7.8) vulnerability affecting ffi, ruby-ffi (ruby-ffi project).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.2% of all vulnerabilities.
- Fix: update to 1.9.24 or later.
| Package | Affected versions | Patched versions |
|---|
| ffi RubyGems | < 1.9.24
| 1.9.24
|
| ruby-ffi | ≤ 1.9.23
| No fix yet |
Description
ruby-ffi version 1.9.23 and earlier has a DLL loading issue which can be hijacked on Windows OS, when a Symbol is used as DLL name instead of a String This vulnerability appears to have been fixed in v1.9.24 and later.
NVD description
ruby-ffi version 1.9.23 and earlier has a DLL loading issue which can be hijacked on Windows OS, when a Symbol is used as DLL name instead of a String This vulnerability appears to have been fixed in v1.9.24 and later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free