In short
- CVE-2018-1000211 is a HIGH (CVSS 7.5) vulnerability affecting doorkeeper, doorkeeper (doorkeeper project).
- Chance of exploitation in the next 30 days (EPSS): 1.6%, higher than 75.2% of all vulnerabilities.
- Fix: update to 4.4.0 or later.
| Package | Affected versions | Patched versions |
|---|
| doorkeeper RubyGems | ≥ 4.2.0, < 4.4.0
| 4.4.0
|
| doorkeeper | ≤ 4.2.0
| No fix yet |
Description
Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in Token revocation API's authorized method that can result in Access tokens are not revoked for public OAuth apps, leaking access until expiry.
NVD description
Doorkeeper version 4.2.0 and later contains a Incorrect Access Control vulnerability in Token revocation API's authorized method that can result in Access tokens are not revoked for public OAuth apps, leaking access until expiry.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free