In short
- CVE-2018-1000424 is a HIGH (CVSS 7.8) vulnerability affecting org.jenkins-ci.plugins:artifactory, artifactory (jfrog).
- Chance of exploitation in the next 30 days (EPSS): 0.33%, higher than 26.5% of all vulnerabilities.
- Fix: update to 2.16.2 or later.
Description
An insufficiently protected credentials vulnerability exists in Jenkins Artifactory Plugin 2.16.1 and earlier in ArtifactoryBuilder.java, CredentialsConfig.java that allows attackers with local file system access to obtain old credentials configured for the plugin before it integrated with Credentials Plugin.
NVD description
An insufficiently protected credentials vulnerability exists in Jenkins Artifactory Plugin 2.16.1 and earlier in ArtifactoryBuilder.java, CredentialsConfig.java that allows attackers with local file system access to obtain old credentials configured for the plugin before it integrated with Credentials Plugin.
More vulnerabilities in org.jenkins-ci.plugins:artifactory
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free