In short
- CVE-2018-1000425 is a HIGH (CVSS 7.8) vulnerability affecting org.jenkins-ci.plugins:sonar, sonarqube scanner (sonarsource).
- Chance of exploitation in the next 30 days (EPSS): 0.34%, higher than 28.0% of all vulnerabilities.
- Fix: update to 2.8.1 or later.
Description
An insufficiently protected credentials vulnerability exists in Jenkins SonarQube Scanner Plugin 2.8 and earlier in SonarInstallation.java that allows attackers with local file system access to obtain the credentials used to connect to SonarQube.
NVD description
An insufficiently protected credentials vulnerability exists in Jenkins SonarQube Scanner Plugin 2.8 and earlier in SonarInstallation.java that allows attackers with local file system access to obtain the credentials used to connect to SonarQube.
More vulnerabilities in org.jenkins-ci.plugins:sonar
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free