In short
- CVE-2018-1000516 is a MEDIUM (CVSS 6.1) vulnerability affecting galaxy-app, galaxy (galaxyproject).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.4% of all vulnerabilities.
- Fix: update to 15.01, 14.10.1 or later.
| Package | Affected versions | Patched versions |
|---|
| galaxy-app PyPI | ≥ 15.0, < 15.01< 14.10.1
| 15.0114.10.1
|
| galaxy | = 14.10
| No fix yet |
Description
The Galaxy Project Galaxy version v14.10 contains a CWE-79: Improper Neutralization of Input During Web Page Generation vulnerability in Many templates used in the Galaxy server did not properly sanitize user's input, which would allow for cross-site scripting (XSS) attacks. In this form of attack, a malicious person can create a URL which, when opened by a Galaxy user or administrator, would allow the malicious user to execute arbitrary Javascript. that can result in Arbitrary JavaScript code execution. This attack appear to be exploitable via The victim must interact with component on page witch contains injected JavaScript code.. This vulnerability appears to have been fixed in v14.10.1, v15.01.
NVD description
The Galaxy Project Galaxy version v14.10 contains a CWE-79: Improper Neutralization of Input During Web Page Generation vulnerability in Many templates used in the Galaxy server did not properly sanitize user's input, which would allow for cross-site scripting (XSS) attacks. In this form of attack, a malicious person can create a URL which, when opened by a Galaxy user or administrator, would allow the malicious user to execute arbitrary Javascript. that can result in Arbitrary JavaScript code execution. This attack appear to be exploitable via The victim must interact with component on page witch contains injected JavaScript code.. This vulnerability appears to have been fixed in v14.10.1, v15.01.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free