In short
- CVE-2018-1000814 is a MEDIUM (CVSS 6.5) vulnerability affecting aiohttp-session, aiohttp session (aio-libs).
- Chance of exploitation in the next 30 days (EPSS): 0.97%, higher than 61.9% of all vulnerabilities.
- Fix: update to 2.7.0 or later.
Description
aio-libs aiohttp-session version 2.6.0 and earlier contains a Other/Unknown vulnerability in EncryptedCookieStorage and NaClCookieStorage that can result in Non-expiring sessions / Infinite lifespan. This attack appear to be exploitable via Recreation of a cookie post-expiry with the same value.
NVD description
aio-libs aiohttp-session version 2.6.0 and earlier contains a Other/Unknown vulnerability in EncryptedCookieStorage and NaClCookieStorage that can result in Non-expiring sessions / Infinite lifespan. This attack appear to be exploitable via Recreation of a cookie post-expiry with the same value.
More vulnerabilities in aiohttp-session
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free