In short
- CVE-2018-1000872 is a MEDIUM (CVSS 6.5) vulnerability affecting pykmip, pykmip (pykmip project).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.4% of all vulnerabilities.
- Fix: update to 0.8.0 or later.
| Package | Affected versions | Patched versions |
|---|
| pykmip PyPI | < 0.8.0
| 0.8.0
|
| pykmip | < 0.8.0
| 0.8.0
|
Description
OpenKMIP PyKMIP version All versions before 0.8.0 contains a CWE 399: Resource Management Errors (similar issue to CVE-2015-5262) vulnerability in PyKMIP server that can result in DOS: the server can be made unavailable by one or more clients opening all of the available sockets. This attack appear to be exploitable via A client or clients open sockets with the server and then never close them. This vulnerability appears to have been fixed in 0.8.0.
NVD description
OpenKMIP PyKMIP version All versions before 0.8.0 contains a CWE 399: Resource Management Errors (similar issue to CVE-2015-5262) vulnerability in PyKMIP server that can result in DOS: the server can be made unavailable by one or more clients opening all of the available sockets. This attack appear to be exploitable via A client or clients open sockets with the server and then never close them. This vulnerability appears to have been fixed in 0.8.0.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free