In short
- CVE-2018-1082 is a HIGH (CVSS 8.1) vulnerability affecting moodle/moodle, moodle (moodle).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.7% of all vulnerabilities.
- Fix: update to 3.3.5, 3.4.2 or later.
| Package | Affected versions | Patched versions |
|---|
| moodle/moodle Packagist | ≥ 3.3, < 3.3.5≥ 3.4, < 3.4.2
| 3.3.53.4.2
|
| moodle | ≥ 3.3.0, ≤ 3.3.4≥ 3.4.0, ≤ 3.4.1
| No fix yet |
Description
A flaw was found in Moodle 3.4 to 3.4.1, and 3.3 to 3.3.4. If a user account using OAuth2 authentication method was once confirmed but later suspended, the user could still login to the site.
NVD description
A flaw was found in Moodle 3.4 to 3.4.1, and 3.3 to 3.3.4. If a user account using OAuth2 authentication method was once confirmed but later suspended, the user could still login to the site.
More vulnerabilities in moodle/moodle
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free