In short
- CVE-2018-1098 is a HIGH (CVSS 8.8) vulnerability affecting go.etcd.io/etcd/v3, etcd (redhat).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.8% of all vulnerabilities.
- Fix: update to 3.4.0 or later.
Description
A cross-site request forgery flaw was found in etcd 3.3.1 and earlier. An attacker can set up a website that tries to send a POST request to the etcd server and modify a key. Adding a key is done with PUT so it is theoretically safe (can't PUT from an HTML form or such) but POST allows creating in-order keys that an attacker can send.
NVD description
A cross-site request forgery flaw was found in etcd 3.3.1 and earlier. An attacker can set up a website that tries to send a POST request to the etcd server and modify a key. Adding a key is done with PUT so it is theoretically safe (can't PUT from an HTML form or such) but POST allows creating in-order keys that an attacker can send.
More vulnerabilities in go.etcd.io/etcd/v3
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free