In short
- CVE-2018-11688 is a MEDIUM (CVSS 6.1) vulnerability affecting org.igniterealtime.openfire:parent, openfire (igniterealtime).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 83.8% of all vulnerabilities.
- Fix: update to 3.9.2 or later.
Description
Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.
NVD description
Ignite Realtime Openfire before 3.9.2 is vulnerable to cross-site scripting, caused by improper validation of user-supplied input. A remote attacker could exploit this vulnerability via a crafted URL to execute script in a victim's Web browser within the security context of the hosting Web site, once the URL is clicked. An attacker could use this vulnerability to steal the victim's cookie-based authentication credentials.
More vulnerabilities in org.igniterealtime.openfire:parent
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free