| Package | Affected versions | Patched versions |
|---|---|---|
| org.apache.struts:struts2-rest-plugin | ≥ 2.1.1, < 2.5.16 | 2.5.16 |
| struts | ≥ 2.1.1, ≤ 2.5.14.1 |
The Apache Struts REST Plugin is using XStream library which is vulnerable and allow perform a DoS attack when using a malicious request with specially crafted XML payload. Upgrade to the Apache Struts version 2.5.16 and switch to an optional Jackson XML handler as described here http://struts.apache.org/plugins/rest/#custom-contenttypehandlers. Another option is to implement a custom XML handler based on the Jackson XML handler from the Apache Struts 2.5.16.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free