In short
- CVE-2018-1340 is a HIGH (CVSS 7.5) vulnerability affecting org.apache.guacamole:guacamole-common, guacamole (apache).
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 81.2% of all vulnerabilities.
- Fix: update to 1.0.0 or later.
Description
Prior to 1.0.0, Apache Guacamole used a cookie for client-side storage of the user's session token. This cookie lacked the "secure" flag, which could allow an attacker eavesdropping on the network to intercept the user's session token if unencrypted HTTP requests are made to the same domain.
NVD description
Prior to 1.0.0, Apache Guacamole used a cookie for client-side storage of the user's session token. This cookie lacked the "secure" flag, which could allow an attacker eavesdropping on the network to intercept the user's session token if unencrypted HTTP requests are made to the same domain.
More vulnerabilities in org.apache.guacamole:guacamole-common
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free