In short
- CVE-2018-14404 is a MEDIUM (CVSS 6.5) vulnerability affecting nokogiri, libxml2 (xmlsoft).
- Chance of exploitation in the next 30 days (EPSS): 3.7%, higher than 89.9% of all vulnerabilities.
- Fix: update to 1.8.5 or later.
| Package | Affected versions | Patched versions |
|---|
| nokogiri RubyGems | < 1.8.5
| 1.8.5
|
| libxml2 | ≤ 2.9.8
| No fix yet |
Description
A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulnerable to a denial of service attack due to a crash of the application.
NVD description
A NULL pointer dereference vulnerability exists in the xpath.c:xmlXPathCompOpEval() function of libxml2 through 2.9.8 when parsing an invalid XPath expression in the XPATH_OP_AND or XPATH_OP_OR case. Applications processing untrusted XSL format inputs with the use of the libxml2 library may be vulnerable to a denial of service attack due to a crash of the application.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free