In short
- CVE-2018-15178 is a MEDIUM (CVSS 6.1) vulnerability affecting gogs.io/gogs, gogs (gogs).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 70.8% of all vulnerabilities.
- Fix: update to 0.12.0, 0.12 or later.
| Package | Affected versions | Patched versions |
|---|
| gogs.io/gogs Go | < 0.12.0
| 0.12.0
|
| gogs | < 0.12
| 0.12
|
Description
Open redirect vulnerability in Gogs before 0.12 allows remote attackers to redirect users to arbitrary websites and conduct phishing attacks via an initial /\ substring in the user/login redirect_to parameter, related to the function isValidRedirect in routes/user/auth.go.
NVD description
Open redirect vulnerability in Gogs before 0.12 allows remote attackers to redirect users to arbitrary websites and conduct phishing attacks via an initial /\ substring in the user/login redirect_to parameter, related to the function isValidRedirect in routes/user/auth.go.
More vulnerabilities in gogs.io/gogs
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free