In short
- CVE-2018-15560 is a HIGH (CVSS 7.5) vulnerability affecting pycryptodome, pycryptodome (pycryptodome).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.0% of all vulnerabilities.
- Fix: update to 3.6.6 or later.
Description
PyCryptodome before 3.6.6 has an integer overflow in the data_len variable in AESNI.c, related to the AESNI_encrypt and AESNI_decrypt functions, leading to the mishandling of messages shorter than 16 bytes.
NVD description
PyCryptodome before 3.6.6 has an integer overflow in the data_len variable in AESNI.c, related to the AESNI_encrypt and AESNI_decrypt functions, leading to the mishandling of messages shorter than 16 bytes.
More vulnerabilities in pycryptodome
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free