| Package | Affected versions | Patched versions |
|---|---|---|
| electron | = 1.7.15= 1.8.7= 2.0.7= 3.0.0 | |
| electron | ≥ 1.7.0, < 1.7.16≥ 1.8.0, < 1.8.8≥ 2.0.0, < 2.0.8≥ 3.0.0-beta.1, < 3.0.0-beta.7 | 1.7.161.8.82.0.83.0.0-beta.7 |
GitHub Electron 1.7.15, 1.8.7, 2.0.7, and 3.0.0-beta.6, in certain scenarios involving IFRAME elements and "nativeWindowOpen: true" or "sandbox: true" options, is affected by a webPreferences vulnerability that can be leveraged to perform remote code execution.
More information to determine if you are impacted can be found on the electron blog.
Upgrade Electron to >=3.0.0-beta.7, >=2.0.8, >=1.8.8, or >=1.7.16.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free