In short
- CVE-2018-16480 is a MEDIUM (CVSS 6.1) vulnerability affecting public (public project), public.
- Chance of exploitation in the next 30 days (EPSS): 0.77%, higher than 55.8% of all vulnerabilities.
- Fix: update to 0.1.4 or later.
| Package | Affected versions | Patched versions |
|---|
| public | < 0.1.4
| 0.1.4
|
| public npm | < 0.1.4
| 0.1.4
|
Description
A XSS vulnerability was found in module public <0.1.4 that allows malicious Javascript code to run in the browser, due to the absence of sanitization of the file/folder names before rendering.
NVD description
A XSS vulnerability was found in module public <0.1.4 that allows malicious Javascript code to run in the browser, due to the absence of sanitization of the file/folder names before rendering.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free