In short
- CVE-2018-16485 is a MEDIUM (CVSS 6.5) vulnerability affecting m-server (m-server project), m-server.
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.3% of all vulnerabilities.
- Fix: update to 1.4.1 or later.
| Package | Affected versions | Patched versions |
|---|
| m-server | < 1.4.1
| 1.4.1
|
| m-server npm | < 1.4.1
| 1.4.1
|
Description
Path Traversal vulnerability in module m-server <1.4.1 allows malicious user to access unauthorized content of any file in the directory tree e.g. /etc/passwd by appending slashes to the URL request.
NVD description
Path Traversal vulnerability in module m-server <1.4.1 allows malicious user to access unauthorized content of any file in the directory tree e.g. /etc/passwd by appending slashes to the URL request.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free