In short
- CVE-2018-16491 is a CRITICAL (CVSS 9.8) vulnerability affecting node.extend (dreamerslab), node.extend.
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.6% of all vulnerabilities.
- Fix: update to 2.0.1, 1.1.7 or later.
| Package | Affected versions | Patched versions |
|---|
| node.extend | ≥ 2.0.0, < 2.0.1< 1.1.7
| 2.0.11.1.7
|
| node.extend npm | ≥ 2.0.0, < 2.0.1< 1.1.7
| 2.0.11.1.7
|
Description
Versions of node.extend before 1.1.7 or 2.0.1 are vulnerable to prototype pollution.
Recommendation
Update to version 1.1.7, 2.0.1 or later.
NVD description
A prototype pollution vulnerability was found in node.extend <1.1.7, ~<2.0.1 that allows an attacker to inject arbitrary properties onto Object.prototype.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free