In short
- CVE-2018-16515 is a HIGH (CVSS 8.8) vulnerability affecting matrix-synapse, synapse (matrix).
- Chance of exploitation in the next 30 days (EPSS): 1.5%, higher than 74.9% of all vulnerabilities.
- Fix: update to 0.33.3.1, 0.33.2.1 or later.
| Package | Affected versions | Patched versions |
|---|
| matrix-synapse PyPI | ≥ 0.33.3, < 0.33.3.1< 0.33.2.1
| 0.33.3.10.33.2.1
|
| synapse | < 0.33.3.1
| 0.33.3.1
|
Description
Matrix Synapse before 0.33.3.1 and 0.33.2.1 allows remote attackers to spoof events and possibly have unspecified other impacts by leveraging improper transaction and event signature validation.
NVD description
Matrix Synapse before 0.33.3.1 allows remote attackers to spoof events and possibly have unspecified other impacts by leveraging improper transaction and event signature validation.
More vulnerabilities in matrix-synapse
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free