In short
- CVE-2018-16974 is a CRITICAL (CVSS 9.8) vulnerability affecting elefant/cms, elefant (elefantcms).
- Chance of exploitation in the next 30 days (EPSS): 3.6%, higher than 89.5% of all vulnerabilities.
- Fix: update to 2.0.7 or later.
| Package | Affected versions | Patched versions |
|---|
| elefant/cms Packagist | < 2.0.7
| 2.0.7
|
| elefant | < 2.0.7
| 2.0.7
|
Description
An issue was discovered in Elefant CMS before 2.0.7. There is a PHP Code Execution Vulnerability in apps/filemanager/upload/drop.php by using /filemanager/api/rm/.htaccess to remove the .htaccess file, and then using a filename that ends in .php followed by space characters (for bypassing the blacklist).
NVD description
An issue was discovered in Elefant CMS before 2.0.7. There is a PHP Code Execution Vulnerability in apps/filemanager/upload/drop.php by using /filemanager/api/rm/.htaccess to remove the .htaccess file, and then using a filename that ends in .php followed by space characters (for bypassing the blacklist).
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free