In short
- CVE-2018-16975 is a CRITICAL (CVSS 9.8) vulnerability affecting elefant/cms, elefant (elefantcms).
- Chance of exploitation in the next 30 days (EPSS): 3.7%, higher than 89.8% of all vulnerabilities.
- Fix: update to 2.0.7 or later.
| Package | Affected versions | Patched versions |
|---|
| elefant/cms Packagist | < 2.0.7
| 2.0.7
|
| elefant | < 2.0.7
| 2.0.7
|
Description
An issue was discovered in Elefant CMS before 2.0.7. There is a PHP Code Execution Vulnerability in /designer/add/stylesheet.php by using a .php extension in the New Stylesheet Name field in conjunction with <?php content, because of insufficient input validation in apps/designer/handlers/csspreview.php.
NVD description
An issue was discovered in Elefant CMS before 2.0.7. There is a PHP Code Execution Vulnerability in /designer/add/stylesheet.php by using a .php extension in the New Stylesheet Name field in conjunction with <?php content, because of insufficient input validation in apps/designer/handlers/csspreview.php.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free