In short
- CVE-2018-17605 is a HIGH (CVSS 7.5) vulnerability affecting org.grails.plugins:asset-pipeline, asset-pipeline (asset pipeline project).
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.5% of all vulnerabilities.
- Fix: update to 3.0.4 or later.
Description
An issue was discovered in the Asset Pipeline plugin before 3.0.4 for Grails. An attacker can perform directory traversal via a crafted request when a servlet-based application is executed in Jetty, because there is a classloader vulnerability that can allow a reverse file traversal route in AssetPipelineFilter.groovy or AssetPipelineFilterCore.groovy.
NVD description
An issue was discovered in the Asset Pipeline plugin before 3.0.4 for Grails. An attacker can perform directory traversal via a crafted request when a servlet-based application is executed in Jetty, because there is a classloader vulnerability that can allow a reverse file traversal route in AssetPipelineFilter.groovy or AssetPipelineFilterCore.groovy.
More vulnerabilities in org.grails.plugins:asset-pipeline
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free