In short
- CVE-2018-18920 is a HIGH (CVSS 8.8) vulnerability affecting evm-py, py-evm, py-evm (ethereum).
- Chance of exploitation in the next 30 days (EPSS): 2.9%, higher than 87.1% of all vulnerabilities.
- Fix: update to 0.2.0a33 or later.
| Package | Affected versions | Patched versions |
|---|
| evm-py PyPI | ≤ 0.2.0-alpha\.33
| No fix yet |
| py-evm PyPI | ≤ 0.2.0a33< 0.2.0a33
| 0.2.0a33
|
| py-evm | = 0.2.0
| No fix yet |
Description
Py-EVM v0.2.0-alpha.33 allows attackers to make a vm.execute_bytecode call that triggers computation._stack.values with '"stack": [100, 100, 0]' where b'\x' was expected, resulting in an execution failure because of an invalid opcode. This is reportedly related to "smart contracts can be executed indefinitely without gas being paid."
NVD description
Py-EVM v0.2.0-alpha.33 allows attackers to make a vm.execute_bytecode call that triggers computation._stack.values with '"stack": [100, 100, 0]' where b'\x' was expected, resulting in an execution failure because of an invalid opcode. This is reportedly related to "smart contracts can be executed indefinitely without gas being paid."
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free