In short
- CVE-2018-19289 is a MEDIUM (CVSS 6.1) vulnerability affecting valine (valine.js), valine.
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.9% of all vulnerabilities.
- Fix: update to 1.3.4 or later.
| Package | Affected versions | Patched versions |
|---|
| valine | = 1.3.3
| No fix yet |
| valine npm | < 1.3.4
| 1.3.4
|
Description
An issue was discovered in Valine v1.3.3. It allows HTML injection, which can be exploited for JavaScript execution via an EMBED element in conjunction with a .pdf file.
NVD description
An issue was discovered in Valine v1.3.3. It allows HTML injection, which can be exploited for JavaScript execution via an EMBED element in conjunction with a .pdf file.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free