In short
- CVE-2018-19352 is a MEDIUM (CVSS 6.1) vulnerability affecting notebook, notebook (jupyter).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 71.2% of all vulnerabilities.
- Fix: update to 5.7.2 or later.
| Package | Affected versions | Patched versions |
|---|
| notebook PyPI | < 5.7.2
| 5.7.2
|
| notebook | < 5.7.2
| 5.7.2
|
Description
Jupyter Notebook before 5.7.2 allows XSS via a crafted directory name because notebook/static/tree/js/notebooklist.js handles certain URLs unsafely.
NVD description
Jupyter Notebook before 5.7.2 allows XSS via a crafted directory name because notebook/static/tree/js/notebooklist.js handles certain URLs unsafely.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free