In short
- CVE-2018-19787 is a MEDIUM (CVSS 6.1) vulnerability affecting lxml, lxml (lxml).
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 84.3% of all vulnerabilities.
- Fix: update to 4.2.5 or later.
| Package | Affected versions | Patched versions |
|---|
| lxml PyPI | < 4.2.5
| 4.2.5
|
| lxml | < 4.2.5
| 4.2.5
|
Description
An issue was discovered in lxml before 4.2.5. lxml/html/clean.py in the lxml.html.clean module does not remove javascript: URLs that use escaping, allowing a remote attacker to conduct XSS attacks, as demonstrated by "j a v a s c r i p t:" in Internet Explorer. This is a similar issue to CVE-2014-3146.
NVD description
An issue was discovered in lxml before 4.2.5. lxml/html/clean.py in the lxml.html.clean module does not remove javascript: URLs that use escaping, allowing a remote attacker to conduct XSS attacks, as demonstrated by "j a v a s c r i p t:" in Internet Explorer. This is a similar issue to CVE-2014-3146.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free