In short
- CVE-2018-1999024 is a MEDIUM (CVSS 5.4) vulnerability affecting mathjax (mathjax), mathjax.
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 73.4% of all vulnerabilities.
- Fix: update to 2.7.4 or later.
| Package | Affected versions | Patched versions |
|---|
| mathjax | < 2.7.4
| 2.7.4
|
| mathjax npm | < 2.7.4
| 2.7.4
|
Description
MathJax version prior to version 2.7.4 contains a Cross Site Scripting (XSS) vulnerability in the \unicode{} macro that can result in Potentially untrusted Javascript running within a web browser. This attack appear to be exploitable via The victim must view a page where untrusted content is processed using Mathjax. This vulnerability appears to have been fixed in 2.7.4 and later.
NVD description
MathJax version prior to version 2.7.4 contains a Cross Site Scripting (XSS) vulnerability in the \unicode{} macro that can result in Potentially untrusted Javascript running within a web browser. This attack appear to be exploitable via The victim must view a page where untrusted content is processed using Mathjax. This vulnerability appears to have been fixed in 2.7.4 and later.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free