In short
- CVE-2018-1999029 is a MEDIUM (CVSS 5.4) vulnerability affecting org.jenkins-ci.plugins:shelve-project-plugin, shelve project (jenkins).
- Chance of exploitation in the next 30 days (EPSS): 0.72%, higher than 54.0% of all vulnerabilities.
- Fix: update to 2.0 or later.
Description
A cross-site scripting vulnerability exists in Jenkins Shelve Project Plugin 1.5 and earlier in ShelveProjectAction/index.jelly, ShelvedProjectsAction/index.jelly that allows attackers with Job/Configure permission to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.
NVD description
A cross-site scripting vulnerability exists in Jenkins Shelve Project Plugin 1.5 and earlier in ShelveProjectAction/index.jelly, ShelvedProjectsAction/index.jelly that allows attackers with Job/Configure permission to define JavaScript that would be executed in another user's browser when that other user performs some UI actions.
More vulnerabilities in org.jenkins-ci.plugins:shelve-project-plugin
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free