In short
- CVE-2018-20303 is a HIGH (CVSS 7.5) vulnerability affecting gogs.io/gogs, gogs (gogs).
- Chance of exploitation in the next 30 days (EPSS): 3.3%, higher than 88.5% of all vulnerabilities.
- Fix: update to 0.11.80-0.20181218063808-ff93d9dbda5c, 0.11.82.1218 or later.
| Package | Affected versions | Patched versions |
|---|
| gogs.io/gogs Go | < 0.11.80-0.20181218063808-ff93d9dbda5c
| 0.11.80-0.20181218063808-ff93d9dbda5c
|
| gogs | < 0.11.82.1218
| 0.11.82.1218
|
Description
In pkg/tool/path.go in Gogs before 0.11.82.1218, a directory traversal in the file-upload functionality can allow an attacker to create a file under data/sessions on the server, a similar issue to CVE-2018-18925.
NVD description
In pkg/tool/path.go in Gogs before 0.11.82.1218, a directory traversal in the file-upload functionality can allow an attacker to create a file under data/sessions on the server, a similar issue to CVE-2018-18925.
More vulnerabilities in gogs.io/gogs
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free