In short
- CVE-2018-20321 is a HIGH (CVSS 8.8) vulnerability affecting github.com/rancher/rancher, rancher (suse).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.1% of all vulnerabilities.
- Fix: update to 2.1.6, 2.1.6+incompatible or later.
| Package | Affected versions | Patched versions |
|---|
| github.com/rancher/rancher Go | ≥ 2.0.0, < 2.1.6≥ 2.0.0+incompatible, < 2.1.6+incompatible
| 2.1.62.1.6+incompatible
|
| rancher | ≥ 2.0.0, ≤ 2.1.5
| No fix yet |
Description
An issue was discovered in Rancher 2 through 2.1.5. Any project member with access to the default namespace can mount the netes-default service account in a pod, and then use that pod to execute administrative privileged commands against the k8s cluster. This could be mitigated by isolating the default namespace in a separate project, where only cluster admins can be given permissions to access. As of 2018-12-20, this bug affected ALL clusters created or imported by Rancher.
NVD description
An issue was discovered in Rancher 2 through 2.1.5. Any project member with access to the default namespace can mount the netes-default service account in a pod, and then use that pod to execute administrative privileged commands against the k8s cluster. This could be mitigated by isolating the default namespace in a separate project, where only cluster admins can be given permissions to access. As of 2018-12-20, this bug affected ALL clusters created or imported by Rancher.
More vulnerabilities in github.com/rancher/rancher
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free