In short
- CVE-2018-20433 is a CRITICAL (CVSS 9.8) vulnerability affecting com.mchange:c3p0, c3p0 (mchange).
- Chance of exploitation in the next 30 days (EPSS): 4.6%, higher than 91.6% of all vulnerabilities.
- Fix: update to 0.9.5.3 or later.
| Package | Affected versions | Patched versions |
|---|
| com.mchange:c3p0 Maven | < 0.9.5.3
| 0.9.5.3
|
| c3p0 | = 0.9.5.2
| No fix yet |
Description
c3p0 0.9.5.2 allows XXE in extractXmlConfigFromInputStream in com/mchange/v2/c3p0/cfg/C3P0ConfigXmlUtils.java during initialization.
NVD description
c3p0 0.9.5.2 allows XXE in extractXmlConfigFromInputStream in com/mchange/v2/c3p0/cfg/C3P0ConfigXmlUtils.java during initialization.
More vulnerabilities in com.mchange:c3p0
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free