In short
- CVE-2018-20835 is a HIGH (CVSS 7.5) vulnerability affecting tar-fs (tar-fs project), tar-fs.
- Chance of exploitation in the next 30 days (EPSS): 2.4%, higher than 83.9% of all vulnerabilities.
- Fix: update to 1.16.2 or later.
| Package | Affected versions | Patched versions |
|---|
| tar-fs | < 1.16.2
| 1.16.2
|
| tar-fs npm | < 1.16.2
| 1.16.2
|
Description
A vulnerability was found in tar-fs before 1.16.2. An Arbitrary File Overwrite issue exists when extracting a tarball containing a hardlink to a file that already exists on the system, in conjunction with a later plain file with the same name as the hardlink. This plain file content replaces the existing file content.
NVD description
A vulnerability was found in tar-fs before 1.16.2. An Arbitrary File Overwrite issue exists when extracting a tarball containing a hardlink to a file that already exists on the system, in conjunction with a later plain file with the same name as the hardlink. This plain file content replaces the existing file content.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free