In short
- CVE-2018-20857 is a HIGH (CVSS 7.5) vulnerability affecting samlr, samlr (zendesk).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 68.3% of all vulnerabilities.
- Fix: update to 2.6.2 or later.
| Package | Affected versions | Patched versions |
|---|
| samlr RubyGems | < 2.6.2
| 2.6.2
|
| samlr | < 2.6.2
| 2.6.2
|
Description
Zendesk Samlr before 2.6.2 allows an XML nodes comment attack such as a name_id node with [email protected] followed by <!---->. and then the attacker's domain name.
NVD description
Zendesk Samlr before 2.6.2 allows an XML nodes comment attack such as a name_id node with [email protected] followed by <!---->. and then the attacker's domain name.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free