In short
- CVE-2018-25007 is a MEDIUM (CVSS 4.3) vulnerability affecting com.vaadin:flow-server, flow (vaadin), vaadin (vaadin).
- Chance of exploitation in the next 30 days (EPSS): 0.57%, higher than 47.4% of all vulnerabilities.
- Fix: update to 1.0.6, 10.0.8, 11.0.3 or later.
| Package | Affected versions | Patched versions |
|---|
| com.vaadin:flow-server Maven | ≥ 1.0.0, < 1.0.6
| 1.0.6
|
| flow | ≥ 1.0.0, < 1.0.6
| 1.0.6
|
| vaadin | ≥ 10.0.0, < 10.0.8≥ 11.0.0, < 11.0.3
| 10.0.811.0.3
|
Description
Missing check in UIDL request handler in com.vaadin:flow-server versions 1.0.0 through 1.0.5 (Vaadin 10.0.0 through 10.0.7, and 11.0.0 through 11.0.2) allows attacker to update element property values via crafted synchronization message.
NVD description
Missing check in UIDL request handler in com.vaadin:flow-server versions 1.0.0 through 1.0.5 (Vaadin 10.0.0 through 10.0.7, and 11.0.0 through 11.0.2) allows attacker to update element property values via crafted synchronization message.
More vulnerabilities in com.vaadin:flow-server
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free