In short
- CVE-2018-25033 is a HIGH (CVSS 8.1) vulnerability affecting admesh, admesh (admesh project).
- Chance of exploitation in the next 30 days (EPSS): 1.1%, higher than 64.9% of all vulnerabilities.
- Fix: update to 0.98.5 or later.
| Package | Affected versions | Patched versions |
|---|
| admesh PyPI | < 0.98.5
| 0.98.5
|
| admesh | ≤ 0.98.4
| No fix yet |
Description
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
NVD description
ADMesh through 0.98.4 has a heap-based buffer over-read in stl_update_connects_remove_1 (called from stl_remove_degenerate) in connect.c in libadmesh.a.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free