In short
- CVE-2018-3722 is a HIGH (CVSS 8.8) vulnerability affecting merge-deep (merge-deep project), merge-deep.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.9% of all vulnerabilities.
- Fix: update to 3.0.1 or later.
Description
Versions of merge-deep before 3.0.1 are vulnerable to prototype pollution via merging functions.
Recommendation
Update to version 3.0.1 or later.
NVD description
merge-deep node module before 3.0.1 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free