In short
- CVE-2018-3723 is a HIGH (CVSS 8.8) vulnerability affecting defaults-deep (defaults-deep project), defaults-deep.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.9% of all vulnerabilities.
- Fix: update to 0.2.4 or later.
Description
Versions of default-deep before 0.2.4 are vulnerable to prototype pollution
Recommendation
Update to version 0.2.4 or later.
NVD description
defaults-deep node module before 0.2.4 suffers from a Modification of Assumed-Immutable Data (MAID) vulnerability, which allows a malicious user to modify the prototype of "Object" via __proto__, causing the addition or modification of an existing property that will exist on all objects.
More vulnerabilities in defaults-deep
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free