In short
- CVE-2018-3729 is a HIGH (CVSS 7.5) vulnerability affecting localhost-now (localhost-now project), localhost-now.
- Chance of exploitation in the next 30 days (EPSS): 2.0%, higher than 80.7% of all vulnerabilities.
- Fix: update to 1.0.2 or later.
Description
Versions of localhost-now before 1.0.2 are vulnerable to path traversal. This allows a remote attacker to read the content of an arbitrary file.
Recommendation
Update to version 1.0.2 or later.
NVD description
localhost-now node module suffers from a Path Traversal vulnerability due to lack of validation of file, which allows a malicious user to read content of any file with known path.
More vulnerabilities in localhost-now
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free