In short
- CVE-2018-3741 is a MEDIUM (CVSS 6.1) vulnerability affecting rails-html-sanitizer, html sanitizer (rubyonrails).
- Chance of exploitation in the next 30 days (EPSS): 1.3%, higher than 69.5% of all vulnerabilities.
- Fix: update to 1.0.4 or later.
Description
There is a possible XSS vulnerability in all rails-html-sanitizer gem versions below 1.0.4 for Ruby. The gem allows non-whitelisted attributes to be present in sanitized output when input with specially-crafted HTML fragments, and these attributes can lead to an XSS attack on target applications. This issue is similar to CVE-2018-8048 in Loofah. All users running an affected release should either upgrade or use one of the workarounds immediately.
NVD description
There is a possible XSS vulnerability in all rails-html-sanitizer gem versions below 1.0.4 for Ruby. The gem allows non-whitelisted attributes to be present in sanitized output when input with specially-crafted HTML fragments, and these attributes can lead to an XSS attack on target applications. This issue is similar to CVE-2018-8048 in Loofah. All users running an affected release should either upgrade or use one of the workarounds immediately.
More vulnerabilities in rails-html-sanitizer
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free