In short
- CVE-2018-3744 is a CRITICAL (CVSS 9.8) vulnerability affecting html-pages (html-pages project), html-pages.
- Chance of exploitation in the next 30 days (EPSS): 2.2%, higher than 82.9% of all vulnerabilities.
- No patched version is listed yet: follow the vendor's advisory in References.
Description
Versions of html-pages before 2.1.0 are vulnerable to path traversal.
Recommendation
Update to version 2.1.0 or later.
NVD description
The html-pages node module contains a path traversal vulnerabilities that allows an attacker to read any file from the server with cURL.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free