In short
- CVE-2018-3746 is a CRITICAL (CVSS 9.8) vulnerability affecting pdfinfojs (pdfinfojs project), pdfinfojs.
- Chance of exploitation in the next 30 days (EPSS): 4.9%, higher than 92.1% of all vulnerabilities.
- Fix: update to 0.4.1 or later.
| Package | Affected versions | Patched versions |
|---|
| pdfinfojs | ≤ 0.3.6
| No fix yet |
| pdfinfojs npm | < 0.4.1
| 0.4.1
|
Description
Versions of pdfinfojs before 0.4.1 are vulnerable to command injection. This is exploitable if an attacker can control the filename parameter that is passed into the pdfinfojs constructor.
Recommendation
Update to version 0.4.1 or later.
NVD description
The pdfinfojs NPM module versions <= 0.3.6 has a command injection vulnerability that allows an attacker to execute arbitrary commands on the victim's machine.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free