In short
- CVE-2018-3749 is a CRITICAL (CVSS 9.8) vulnerability affecting deap (deap project), deap.
- Chance of exploitation in the next 30 days (EPSS): 1.4%, higher than 73.1% of all vulnerabilities.
- Fix: update to 1.0.1 or later.
| Package | Affected versions | Patched versions |
|---|
| deap | < 1.0.1
| 1.0.1
|
| deap npm | < 1.0.1
| 1.0.1
|
Description
The utilities function in all versions < 1.0.1 of the deap node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
NVD description
The utilities function in all versions < 1.0.1 of the deap node module can be tricked into modifying the prototype of Object when the attacker can control part of the structure passed to this function. This can let an attacker add or modify existing properties that will exist on all objects.
Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free