In short
- CVE-2018-6519 is a HIGH (CVSS 7.5) vulnerability affecting simplesamlphp/saml2, saml2 (simplesamlphp).
- Chance of exploitation in the next 30 days (EPSS): 1.7%, higher than 77.2% of all vulnerabilities.
- Fix: update to 2.3.5, 3.1.1, 1.10.4 or later.
| Package | Affected versions | Patched versions |
|---|
| simplesamlphp/saml2 Packagist | ≥ 2.0, < 2.3.5≥ 3.0, < 3.1.1< 1.10.4
| 2.3.53.1.11.10.4
|
| saml2 | ≥ 1.0.0, < 1.10.4≥ 2.0.0, < 2.3.5≥ 3.0.0, < 3.1.1
| 1.10.42.3.53.1.1
|
Description
The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.
NVD description
The SAML2 library before 1.10.4, 2.x before 2.3.5, and 3.x before 3.1.1 in SimpleSAMLphp has a Regular Expression Denial of Service vulnerability for fraction-of-seconds data in a timestamp.
More vulnerabilities in simplesamlphp/saml2
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free