In short
- CVE-2018-7206 is a HIGH (CVSS 8.8) vulnerability affecting oauthenticator, oauthenticator (jupyter).
- Chance of exploitation in the next 30 days (EPSS): 1.8%, higher than 78.2% of all vulnerabilities.
- Fix: update to 0.6.2, 0.7.3 or later.
| Package | Affected versions | Patched versions |
|---|
| oauthenticator PyPI | ≥ 0.6, < 0.6.2≥ 0.7, < 0.7.3
| 0.6.20.7.3
|
| oauthenticator | = 0.6.0= 0.6.1= 0.7.0= 0.7.1= 0.7.2
| No fix yet |
Description
An issue was discovered in Project Jupyter JupyterHub OAuthenticator 0.6.x before 0.6.2 and 0.7.x before 0.7.3. When using JupyterHub with GitLab group whitelisting for access control, group membership was not checked correctly, allowing members not in the whitelisted groups to create accounts on the Hub. (Users were not allowed to access other users' accounts, but could create their own accounts on the Hub linked to their GitLab account. GitLab authentication not using gitlab_group_whitelist is unaffected. No other Authenticators are affected.)
NVD description
An issue was discovered in Project Jupyter JupyterHub OAuthenticator 0.6.x before 0.6.2 and 0.7.x before 0.7.3. When using JupyterHub with GitLab group whitelisting for access control, group membership was not checked correctly, allowing members not in the whitelisted groups to create accounts on the Hub. (Users were not allowed to access other users' accounts, but could create their own accounts on the Hub linked to their GitLab account. GitLab authentication not using gitlab_group_whitelist is unaffected. No other Authenticators are affected.)
More vulnerabilities in oauthenticator
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free