In short
- CVE-2018-7711 is a HIGH (CVSS 8.1) vulnerability affecting simplesamlphp/saml2, saml2 (simplesamlphp), simplesamlphp (simplesamlphp).
- Chance of exploitation in the next 30 days (EPSS): 1.2%, higher than 67.9% of all vulnerabilities.
- Fix: update to 2.3.8, 3.1.4, 1.10.6, 1.15.4 or later.
| Package | Affected versions | Patched versions |
|---|
| simplesamlphp/saml2 Packagist | ≥ 2.0, < 2.3.8≥ 3.0, < 3.1.4< 1.10.6
| 2.3.83.1.41.10.6
|
| saml2 | ≥ 1.0.0, < 1.10.6≥ 2.0.0, < 2.3.8≥ 3.0.0, < 3.1.4
| 1.10.62.3.83.1.4
|
| simplesamlphp | < 1.15.4
| 1.15.4
|
Description
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
NVD description
HTTPRedirect.php in the saml2 library in SimpleSAMLphp before 1.15.4 has an incorrect check of return values in the signature validation utilities, allowing an attacker to get invalid signatures accepted as valid by forcing an error during validation. This occurs because of a dependency on PHP functionality that interprets a -1 error code as a true boolean value.
More vulnerabilities in simplesamlphp/saml2
See all →Running one of these products? Scan your site to see whether it exposes a vulnerable version.
Scan my site free